Wenn das Apple TV AirPlay Icon immer wieder fehlt

Seit dem Apple TV iOS 5.0.1 habe ich ein immer wiederkehrendes AirPlay Problem festgestellt. Nach einer Weile der Nichtbenutzung der Apple TV verschwand das AirPlay Icon von allen Geräten. Freunde von mir berichteten von ähnlichen Problemen.

Ich habe lange gerätselt woran es liegen könnte, bis ich mal in die Netzwerkeinstellungen der Apple TV geschaut habe. Das neue iOS 5.0.1 scheint ein enormes Problem mit der Halten von DHCP Leases zu haben. Sie verliert irgendwann die IP und fordert nicht ordnungsgemäß eine neue an.

Ein Reboot der Apple TV hilft hier allemal, doch niemand möchte seine Apple TV täglich rebooten, oder? Also musste eine andere Lösung her…

So verhinderst Du das verschwinden des AirPlay Icons

Die Lösung ist eigentlich ganz simpel und erfordert nur wenige manuelle Eingriffe. Statt die IP Adresse der Apple TV per DHCP zu beziehen musst Du sie einfach manuell einstellen. Dann ist Ruhe und das AirPlay Icon verschwindet nie wieder von Deinen Devices! Auch nicht, wenn die Apple TV sich im StandBy Modus befindet.

<

h2>IP Adresse der ATV manuell einstellen:

Immer noch Probleme?

Dann könnte vielleicht das hier für Dich interessant werden: Airplay Probleme mit dLAN beheben

Ansonsten habe ich seit dem letzten Update festgestellt, dass man die Apple TV mittlerweile immer erst wach machen muss um das Airplay Symbol wieder-zu bekommen. Im Sleep Mode scheint die irgendwie keinen Wakeup hinzubekommen. Also erst immer auf der Fernbedienung eine TAste drücken, bis die LED der ATV wieder leuchet. Dann ist auch das Airplay Icon wieder da.

Wer übrigens die ATV für einen längere Zeit für Musik via Airplay nutzen möchte, sollte die automatische Stromsparfunktion der ATV ausschalten! Wird nur Musik übertragen, schaltet sich die ATV mit der aktuellen iOS Version seltsamerweise immer wieder in den Standby.

27 Kommentare » Schreibe einen Kommentar

  1. Hallo Viktor,

    ich glaube (hoffe) das ist genau mein Problem. Habe seit ein paar Tagen ein Apple TV 2 (jaillbreak) und bei mir verschwindet regelmäßig das Airplay Symbol vom ipad und vom ipod touch.

    Was bei mir immer klappt (vorübergehend) is kurz den Flugmodus (An-/Ausschalten). Dann wirds sofort wieder angezeigt.

    Hab nur mal kurz ne Frage zur manuellen IP-Adresse. Bin nicht so firm darin. Wie muss ich die einstellen? Wo ich das mache is ja alles klar :)

    Danke schonmal vorab
    Gruß
    hartmut

  2. Nachtrag:

    Reicht es aus wenn ich die Änderung am ATV 2 vornehme? D.h. auf manuelle IP einstellen und die Zahlen vom Router eben selber eintrage/übernhem und halt bei der letzten Zahl eine selber wähle zwischen 1 und 255. Darf halt nur nicht exaxt die gleiche sein wie die des Routers.

    Gruß
    hartmut

  3. IP: 192.168.x.y wobei x gleich und y ungleich der Zahl vom Router
    Subnetz: 255.255.255.0
    Gateway: Die Router IP

  4. Ich werds ausprobieren und dann berichten ob ´s was gebracht hat.
    Hab auch schon was gelesen von Leuten wo das nicht geholfen hat :(

    Bis später :)

    Danke

  5. update:
    Hab so gg. 15:30 eine feste IP vergeben beim ATV. Hatte dann nochmal kurz einen Abbruch bzw. beim iPad war das Airplay Symbol weg.

    Bin dann nochmal in die Alice Box und hab dort unter Heimnetzwerk-LAN, Menupunkt Feste IP-Adressen den ATV deklariert. Und auch dem Gerät nen Namen gegeben (klingt besser *g).

    Das war so 10-15 Min. später. Nun haben wir 18 Uhr und Airplay Symbol is noch da und kann dementsprechend auch genutzt werden. Hoffe es bleibt auch so.

    War es (hoffentlich) entscheidend es auch der Alice Box mitzuteilen das der Apple TV nun eine feste IP hat?

    Und wenn ich beim ATV den Ruhezustand aktiviere, dann geht das Symbol weg. Wenn ich ihn aufwecke erscheint das Airplay Symbol wieder…. also permanent scheint nicht zu funktionieren.

    Werde mich später oder morgen nochmal melden…..

  6. Meine Erfahrung basiert auf der Tatsache, dass ich beim Wecken der ATV in den Einstellungen eine kryptische IP gesehen habe. Das ist immer ein Zeichen dafür, dass die IP nicht korrekt vom DHCP Server zugeteilt wurde und das Gerät sich eine zufällige IP selbst vergeben hat.

    Du hattest erwähnt, dass Du durch das vorübergehende Einschalten des Flugmodus am iPad das Problem lösen konntest. Diese Beobachtung spricht eigentlich gegen das Problem, dass ich hatte. Durch eine erneute Einwahl weckst Du nicht die ATV und erst recht nicht den DHCP Server.

    Die Alice Box hat seit der Umstellung auf die o2 Software eh derbe Probleme! U.A. mit dem DNS http://mizine.de/gadgets/o2-box-4421-dns-problem-beheben/
    Vielleicht fällt hier ein ähnliches Problem ins Gewicht.

  7. Hallo Viktor,

    Du hast Recht. Kurz nachdem ich das letzte Mal gepostet habe war das Airplay Symbol auch wieder weg :-( Hat also nicht daran gelegen. Ein Versuch war es aber wert :)

    Eine kryptische IP konnte ich auch vorher nicht ausmachen.

    Ich mag diese Alice/O2 Box eh nicht !! Hab aber halt auch 3 Handykarten von Alice. Das is ziemlich vorteilhaft. Daher bin ich auch immernoch bei O2 / Alice und dieser „tollen“ Homebox.

    Wie gesagt, sobald ich den Flugmodus Aus und wieder Anschalte erscheint wie von Geisterhand das Airplay Symbol. Is zum Glück kein großer Aufwand Airplay wieder in Gang zu bekommen.

    Denkst Du also es könnte mit dem DNS Problem zusammen hängen? Also mir ist noch nicht aufgefallen das sich Seiten nicht korrekt öffnen lassen o.ä.

    Könnte ja mal einen Test mit dem Reset ausprobieren. Wird dadurch nur (vorübergehend) die alte Software installiert oder sind auch die anderen Einstellungen futsch… z.b. Einwahl Internet usw. ?

    Falls Dir ggf. noch eine Idee zu meinem Problem einfällt bin ich offen für Vorschläge :)

    Gruß

  8. nein, der DNS hat mit diesem Problem nichts am Hut. Aber wenn ein ein DNS Problem da ist, ist ein DHCP Problem nicht weit entfernt. Zumindest ist die Wahrscheinlichkeit einer Fehlfunktion recht hoch.

    Was mich interessieren würde ist, ob Du noch auf das Internet vom iPad aus zugreifen kannst, wenn das AirPlay Symbol weg ist?!

  9. Ok, dann mach ich an der Box lieber nix.

    Ja, sonst geht alles. Is ja dann auch meist so das wenn ich über Youtube mir ein Video anschauen möchte einfach das Symbol fehlt. Es läuft ja quasi schon bzw. wurde geladen usw. Dann gehts kurz in den Flugmodus… dann wieder in Youtube und die Sache läuft….

    Wie gesagt, solange das so geht .. OK. Aber 100% zufrieden bin ich natürlich nicht mit dieser „Lösung“.

    Kanns was mit der Vergabedauer der IP Adressen zu tun haben. Das steht voreingestellt auf 7 Tage. Könnte das auf 30 min. setzen. Dann gibts alle 30 min. ne neue IP. Evtl. hilft das beim Problem.

    Noch eine Info/Hinweis. Hab nen AV-Receiver der auch im Netz hängt. Den bediene ich auch über ne App (Yamaha). Hier wird der Receiver auch ab und zu nicht gefunden. Is mir erst jetzt bewusst geworden. Nach dem Ein-/Ausschalten des Flugmodus findet die App den Receiver wieder. Jetzt das interessante. Beim Samsung S3 meiner Frau wird der Receiver immer gefunden. Auch wenn der iPad den nicht „sieht“ im Netz.

    Kanns evtl. ein WLAN Problem er Apple Geräte sein? In iTunes am PC geht das Airplay Symbol immer !! Auch wenn sich das ATV im Ruhezustand befindet.

    Aber ich hab ehrlich gesagt keine Ahnung woher das kommen kann :(

  10. …. vielleicht is einfach das WLAN der Alice Box nicht „kompatibel“ für eine dauerhafte Anzeige des Airplay Symbols…. Was halt nicht am WLAN im allgemeinen liegt sondern doch an der Alice Home Box…

  11. Hallo Viktor,

    Ich habe ein ähnliches Problem wie Hartmut.
    Sobald ich irgendein Stream über das Internet mit meinem Ipone 4 aktiviere verschwindet am nächsten Tag das Airplay Icon. Ich habe auch schon mit der Hotline von Apple gesprochen. Sie haben mir von einem IP Problem nichts erwähnt und mit das OS neu aufgespielt und dafür 35 € verrechnet. Meine Frage: Wie stelle ich die IP manuell ein? über Apple TV ? über mein Router ? Über das Ipone selbst. Kannst Du mir es wenig deutlicher beschreiben? Ich kann über meinen IP Router ein Gerät direkt eingeben. Er frägt mich dann nach der MAC-Adresse? Trage ich hier die MAC Adresse des IPONES ein? Über ein Feedback würde ich mich feuen. Danke Cengiz

  12. Hallo zusammen. Ich habe erst seit kurzen das appel tv 5.2.1. Ich habe das gerät letzte woche neu installiert und da hatte ich auf allen ipäd und ihones das airplay symbol. Jedoch ist dieses seit zwei tagen verschwunden. Nach studium der oben genannten kommentare und nach änderung der manuellen ip adresse, hat sich leider nichts beimir getan. Auch wenn ich den flugmodus kurz aktiviere, passiert nichts. Was muss ich tun? Bin ratlos? Wer kann mir helfen?

  13. Hallo zusammen. Habe ein ähnliches Problem. Nur bei mir hat die ATV eine feste ip
    Ip. 192.168.10.x
    sühnet 255.255.255.128
    Router und das unterscheiden sich auch da ich den Apple Server hier im Einsatz habe. Jede Hardware hat eine fest ip. Nur nicht die Mobilen bzw. Die Rechner selber. Die beziehen per dhcp. Und trotzdem verschwindet bei meiner ATV 3 das Symbol. Sobald ich abends das iPad oder phone ausmache und morgen eine Verbindung suche klappt nix.. Muss dann jedes mal die ATV neu starten. Dann ist es sofort da. Habe auch schon bei Frau doctor google geschaut und leider nichts gefunden. Dachte ihr habt noch ne Idee ??

  14. Hi.
    Hab genau das gleiche Problem, dass das AirPlay Symbol immer wieder verschwindet. Nach nem Neustart ist’s dann immer wieder da.
    Ich hab bereits ne manuelle ip vergeben hat bisher aber alles nix gebracht.
    Hab n speedport Router von der Telekom.
    Hat noch jemand tips?

  15. Ja, zu Apple einschicken und tauschen lassen. Bei einigen ATVs ist die Netzwerkkarte „kaputt“ und geht in einen deep Sleep Mode, so dass kein Ping mehr möglich ist.

  16. Alternativ könntet Ihr im Router der Mac Adresse der Apple TV ebenfalls eine feste iP zuweisen. Dann werden WakeUp Pings direkt an die Netzwerkkarte der ATV geschickt und nicht mehr per Broadcast an alle im Netz.

  17. Betrifft Apple Airplay. Habe das Ipad 4. Ich denke Apple verschaukelt uns alle. Im Netz gibts darüber jede Menge Beschwerden.
    Fakt ist seit Ios 8 gibt es das Airplay Symbol nur noch in dem aufklapp Menü und bei Youtube. Bei Apple wird immer nur gesagt wie man Airplay aktivieren muß. Kein Wort darüber das es sich seit ios 8 nur noch über das Aufklapp Menü aktivieren läßt.
    Für mich steht fest NIE WIEDER ein Gerät von Apple. So geht man nicht mit Kunden um.

  18. Hallo, Viktor,
    vielen Dank für das Tutorial über die Festlegung der IP – Adresse des ATV. Das hat mein Problem gelöst.

  19. Hallo zusammen

    Habe hier einige iDevices und bin eigentlich ganz zufrieden damit.
    Das einzige Problem war, dass sich sämtliche Apple TVs (2x ATV3 1x ATV4) während dem Airplay verabschiedet haben und mittem im stream abbrachen. Viele User sagten, dass das mit dem dhcp lease zu tun hat. Gesagt getan, ich habe mein Netzwerk mit insgesamt ca. 20 Clients umgestellt und jedem Client eine feste IP vergeben. Bei sämtlichen Clients (Ipads, Iphones, PCs, Smart TV, etc.) funktioniert die statische Adressvergabe einwandfrei. Bei den Apple TV scheint es nicht zu funktionieren.
    Nach der Vergabe der statischen IP Adressen scheinen diese zwar auf und man kann von Iphones und dgl. streamen, jedoch haben keine von ihnen eine Internetverbindung.
    Eine Idee, woran das liegen könnte?
    Danke
    LG
    Niko

  20. Hast Du das Gateway und den DNS korrekt auf die IP des Routers eingestellt?

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.